Trotz WLAN und richtiger IP keine Internetverbindung

Hier findet Ihr Themen rund um Debian und debianbasierte Abkömmlinge

Moderatoren: Administration, Linux-Supporter

Trotz WLAN und richtiger IP keine Internetverbindung

Beitragvon xell83 » 2008-12-22, 12:53

Moin,

ich habe seit meinem Problem mit dem nm-applet nur noch Probleme mit meiner WLAN Verbindung. Kurioser Weise tritt das Problem aber fast nur zuhause in meinem WLAN auf. Folgende Symptome:

- WLAN aktiv, IP per DHCP, DNS automatisch
alles zugewiesen und per ifconfig gecheckt
- ping auf meinen Router funktioniert nicht
- ping auf externe Adresse funktioniert ebenfalls nicht

Soll heißen, dass ich trotz richtiger Einstellungen keinen Rechner anpingen kann. Und da ich meinen Router auch nicht erreiche , komme ich auch nicht ins Internet.
Ich habe auch schon versucht die WLAN Verbindung zu löschen und alles per Hand einzutragen. Keine Abhilfe. Ich verzweifel langsam. Warum komme ich trotz vollen Empfangs und richtiger Einstellungen nicht ins Internet, geschweige denn auf meinen Router ? Der DHCP scheint ja zu funktionieren.

Bei einem Kumpel wurde anfangs das WLAN gar nicht gefunden, obwohl es vorhanden war. Nach einem Neustart funktionierte es wie von Geisterhand wieder. Zuhause klappt aber auch das nicht.
Wenn ich bei uns in der Uni bin, dann komme ich auf die Loginseite vom Proxy , kann mich einloggen und alles funktioniert reibungslos.

Hab mich auch in einigen config Dateien umgesehen , aber keine Fehler gefunden.
Benutzeravatar
xell83
Auszubildender
Auszubildender
 
Beiträge: 46
Registriert: 2007-01-24, 19:59
 

Re: Trotz WLAN und richtiger IP keine Internetverbindung

Beitragvon MaTze » 2008-12-22, 13:35

Was zeigen denn
Code: Alles auswählen
sudo ifconfig ethx
Bsp.: sudo ifconfig eth0
sowie
Code: Alles auswählen
sudo ethtool ethx
Bsp.: sudo ethtool eth0
? Wie sehen der nutzbare IP-Bereich und das Gateway usw. aus?

Schonmal geschaut ob das mit dem Internet funktioniert, wenn du die Sachen von Hand (genauer gesagt per Konsole) festlegst (IP usw.)? Wenn du eine freie IP wählst und den richtigen DNS-Server bzw. das richtige Gateway einträgst, dann sollte es deinen Router ja eigentlich erstmal nicht stören. Kannst es ja zumindest mal ausprobieren. Per Konsole dafür:

IP-Adresse festlegen:
Code: Alles auswählen
sudo ifconfig ethx Rechner-IP
Bsp.: sudo ifconfig eth0 192.168.178.30

Gateway festlegen:
Code: Alles auswählen
sudo route add default gw Router-IP
Bsp.: sudo route add defaul gw 192.168.178.1

Keine Garantie, dass es beim WLAN funktioniert - beim normalen LAN geht's. Hab mit meinem Ubuntu auch diverse Probleme und muss die Sachen erstmal von Hand eintippen, damit Internet läuft (obwohl in den Config-Dateien alles sauber aussieht)...

Alternativ könntest du auch WICD verwenden (belesen wäre aber sicherlich trotzdem gut, hab's noch nicht probiert). Dafür musst du aber wohl noch network-manager sowie network-manager-gnome entfernen.
Zuletzt geändert von MaTze am 2008-12-22, 13:44, insgesamt 3-mal geändert.

AMD X6 1090T @ 1,25 V | ASRock 870 Extreme3 | 16 GB G.Skill RipJaws | GTX 660 | Samsung SSD 470 Series 128 GB | WD Green 2 TB 64 MB Cache | LG GH20NS
Benutzeravatar
MaTze
Allwissend
Allwissend
Junior-Admin
VIP
 
Beiträge: 2449
Registriert: 2003-09-30, 08:54
Wohnort: Bergisch Gladbach
 

Re: Trotz WLAN und richtiger IP keine Internetverbindung

Beitragvon xell83 » 2008-12-22, 22:35

So hab den Fehler gefunden glaub ich.
Hab ne config gefunden, die ich vor Tagen mal angepaßt hab, da beim Bootvorgang immer was hing bezüglich Netzwerk und DHCP.
Um genau zu sein war es die /etc/network/interfaces die ich angepaßt hatte. Dort hab ich eigentlich nur für die LAN Verbindung statische Daten hinterlegt. Irgendwie hat sich das auch negativ auf meine WLAN Verbindung ausgewirkt. Nunja.. hab jetzt alles wieder auf Anfang und siehe da, es geht wieder. Mal sehen wie lange.

Also danke für die Antwort.
Benutzeravatar
xell83
Auszubildender
Auszubildender
 
Beiträge: 46
Registriert: 2007-01-24, 19:59
 



Ähnliche Artikel

 

Zurück zu (K)Ubuntu und Debian



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste

cron